Setup Mac mini 8,1 for Pleiades

macOS

  1. Setup macOS (user registration)
  2. System Preferences:
    • Hostname
    • Remote Login
    • Remote Management
    • Never Sleep
  3. Recovery Mode
    • Secure Boot: No Security
    • External Boot: Allow booting from external media
  4. root password
  5. System Preferences: Don't Sleep
  6. user environment:
    • change shell : dscl . change /users/user UserShell /bin/zsh /bin/csh (on Terminal.app)
    • change uid : dscl . change /users/user UniqueID 501 1001 (on Terminal.app)
    • find / -uid 501 -exec chown -h 1001 {} \; -print
    • ~/.login
    • ~/.cshrc
  7. SSH:
    • ~/.ssh/authorized_keys
    • /etc/ssh/sshd_config:
      • X11Forwarding yes
      • XAuthLocation /opt/X11/bin/xauth
  8. NFS:
    • nfs://nakedsun.db.tokushima-u.ac.jp/Volumes/Pleiades/share/macOS
  9. snmpd:
    • /etc/snmp/snmpd.conf
    • launchctl load -w /System/Library/LaunchDaemons/org.net-snmp.snmpd.plist
  10. VirtualBox:
    • Memory: 32768 MB
    • HDD: VDI, Fixed size, 96 GB, SAS
    • Network: Bridge
    • Processor: 6 CPU

Operating System

  1. Install FreeBSD 12.2
  2. root password
  3. User(alex)
  4. /etc/fstab
    • Comment unneccesary swap
    • Add noatime option
  5. mkdir /home
  6. mkdir /home1
  7. /etc/amd.map
  8. rc.conf
  9. /etc/resolv.conf
  10. usr.staff.alex.tar
  11. home1.edb.tar
  12. /usr/local/share/fonts/OTF
  13. /etc/ssh/sshd_config: +ChallengeResponseAuthentication no
  14. /etc/hosts.allow
  15. /etc/ipf.rules
  16. /etc/make.conf
  17. /etc/aliases
  18. /etc/snmpd.conf
  19. /etc/daily.local
  20. /etc/periodic.conf
  21. touch /etc/exports
  22. /etc/ttys
  23. rm -rf /usr/src ; mkdir /usr/src
  24. cd /usr/src
  25. svnlite co svn://svn.db.tokushima-u.ac.jp/base/releng/12.2/ .
  26. Configure /usr/src/sys/arch/conf/$KERNCONF
  27. rm -rf /usr/obj
  28. make buildworld
  29. make buildkernel
  30. make installkernel
  31. reboot
  32. mergemaster -p
  33. make installworld
  34. mergemaster -iFU
  35. yes | make delete-old
  36. reboot

Mail System

  1. cd /etc/mail
  2. make install
  3. newaliases

Ports Collection / User Application

  1. rm -rf /usr/ports ; mkdir /usr/ports
  2. cd /usr/ports
  3. svnlite co svn://svn.db.tokushima-u.ac.jp/ports/head/ .
  4. Reinstall /usr/ports/ports-mgmt/pkg
  5. Install Ports
    • /usr/ports/ports-mgmt/portupgrade
  6. portupgrade -afc
  7. Install Ports
    • devel/subversion
    • net-mgmt/net-snmp
    • x11/xauth
    • x11-toolkits/libXaw
    • japanese/nkf
    • japanese/less
    • converters/base64
    • devel/imake
    • net/rsync
    • java/openjdk8

Operating System

  1. cd /usr/src
  2. yes | make delete-old-libs

EDB/Java RMI

  1. Add user edb: group edb
  2. cd /usr/local/etc/rc.d/
  3. cp /home/private/edbjavarmi/rc.d/edbjavarmi .

MDMFS

  1. dd if=/dev/zero of=edb bs=1k count=512k
  2. mdconfig -f edb -u 0
  3. newfs -n md0
  4. /etc/fstab: md /home1/edb mfs rw,async,noatime,-nP,-F/home1/mfs/edb 2 0